Jun. 22nd, 2011

One of the problems I've been facing lately is because of Windows' combination of case-preservation and case-insensitivity in file names, specifically dealing with the 'version' and 'Version::Requirements' modules which are both required for ExtUtils::MakeMaker nowadays.

You end up with perl/lib/version/Requirements.pm as a filename, or perl/lib/Version/vpp.pm and vxs.pm - usually the first one.

(in retrospect, Version::Requirements was a bad name for that module for exactly this reason - but if you come from a Unix background, it's not something you think of when naming your modules!)

I need to use the development version in order to get MYMETA files, which I plan to start using soon, so don't say 'The current release version doesn't use Version::Requirements, so you could use it!' That's just delaying the problem.

The fact is that an MSI will throw warnings when creating an installer that would install two files with names that would be the same, given Windows' file name semantics - and rightfully so. So creating builds that install the correct filename is now becoming a problem that I have to solve. And yes, this is delaying 5.12.4 and 5.14.x builds. I'm working on this as quickly as I can, given the other demands on my time. I think I have it solved now, and am running a test 5.12.4 x64 build right now. Then I'll start in on 5.14.1.

I have had a few people contact me in response to my request for help last week on FLOSS Weekly. If I haven't contacted you back yet, don't assume I've forgotten about you - I haven't. The same reasons for needing the help are the reasons I haven't contacted you back yet (that and I need to get a little more infrastructure written and in place!) I'll get to you soon!

Profile

csjewell

June 2011

S M T W T F S
   1234
567891011
12131415161718
192021 22232425
2627282930  

Style Credit

Page generated Aug. 30th, 2014 10:14 pm
Powered by Dreamwidth Studios

Expand Cut Tags

No cut tags

Most Popular Tags

Page Summary